Aktualna wersja: PHP 7.3 (najnowsza wersja)

W dzisiejszym artykule pochylimy się z jednej strony nad aktualizacją wersji PHP po stronie serwera, a pracą na WordPressie z drugiej strony.

Po stronie serwera posiadaliśmy, powiedzmy, wersję 5.4 

 

Jeśli chcemy zmienić na wersję 7.3, a mamy nieodpowiednie wtyczki do WordPressa, które nie będą współgrały z aktualną wersją PHP to otrzymamy komunikaty:

Use of undefined constant AMP_QUERY_VAR – assumed ‘AMP_QUERY_VAR’ (this will throw an Error in a future version of PHP)

Fatal error: ‘break’ not in the ‘loop’ or ‘switch’ context in /public_html/wp-content/plugins/facebook/social-plugins/widgets/like-box.php on line 84

 

Musimy sprawdzić czy posiadamy wtyczki i je wyłączyć:

Na koniec możemy cieszyć się wersją:

This site uses Akismet to reduce spam. Learn how your comment data is processed.